Skip to main content
Version: Next

Prerequisites

Before you can deploy the available data services in PDS, you need to login with valid Admin credentials and add a Kubernetes cluster to PDS. However, in order to use your cluster with PDS, you need to first install Portworx Enterprise in your environment.
For more information about the minimum requirements to install Portworx Enterprise, refer to the Prerequisites page.

This topic includes the recommended hardware, network, software, Kubernetes requirements specifically to use PDS.

Installation prerequisites

The minimum supported size for a Portworx cluster is three nodes. Each node must meet the PDS prerequisites:

Hardware

Hardware

Requirements

CPU

  • Minimum: 4 cores

  • Recommended: 8 cores

RAM

  • Minimum: 8 GB

  • Recommended: 16 GB

Disk

Refer to the Portworx Enterprise installation prerequisites section for minimum drive requirements.

Backing drive

Refer to the Portworx Enterprise installation prerequisites section for backing drive requirements.

Storage drives

Refer to the Portworx Enterprise installation prerequisites section for storage drives requirements.

Network connectivity

Bandwidth:

  • Minimum: 1 Gbps
  • Recommended: 10 Gbps

Network

Network

Requirements

Open needed ports

Static IPv4 addresses that you can whitelist in your firewall rules

List of supported static IPv4 addresses

Software

Refer to the Portworx Enterprise software requirements table under the installation prerequisites section to know the minimum software requirements for PDS.

Supported Kubernetes versions and platforms

Before you install PDS, ensure to use one of the following supported Kubernetes version. Also, PDS supports clusters only on the below listed platforms:

Platform

Version

On-premise Kubernetes

  • 1.25

  • 1.26

  • 1.27

Managed Kubernetes

  • AKS: 1.24, 1.25, 1.26

  • EKS: 1.23, 1.24, 1.25

  • GKE: 1.23.8-gke.1900

  • Anthos: 1.23.15-gke.2400

  • Rancher Kubernetes Engine (RKE1): 1.23.8

  • RKE2: 1.24.12+rke2r1, 1.25.6+rke2r1

Distribution Kubernetes

  • OpenShift 4.11: 1.24

  • OpenShift 4.12: 1.25

  • OpenShift 4.13: 1.26

vSphere with Tanzu (TKGs)

1.22.9+vmware.1-tkg.1.cc71bc8

note

From the PDS 110 release, you must install the PDS Helm chart version 1.9.0 or newer to ensure new PostgreSQL versions are compatible with older chart versions (until 1.8.1).

Supported Portworx versions

Ensure that you install one of the following Portworx Enterprise versions, before using PDS:

  • 3.0.x
  • 2.13.x
  • 2.12.x
note

IMPORTANT

From the PDS 113 release, support for the following legacy Portworx installations is deprecated:

  • Portworx with CSI driver disabled: By default, the CSI driver will be enabled on new Portworx installations. On the older Portworx installations, you can enable the CSI driver.
  • DaemonSet installation: PDS is compatible with the Portworx Operator installation. You can migrate the existing Portworx installed from a DaemonSet to the Operator.

Note that, currently, Portworx provides technical support for the above mentioned legacy Portworx installations. This support may not be available in the future PDS releases.

Backup Targets

PDS supports backup targets on the following storage providers:

Was this page helpful?